.Net ramblings
# Friday, 02 March 2007
FIX: VS 2005 crashes randomly when using Crystal Reports
Here is the event log crash entry:

Faulting application devenv.exe, version 8.0.50727.762, time stamp 0x45716759, faulting module craxddrt.dll_unloaded, version 0.0.0.0,
time stamp 0x43068582, exception code 0xc0000005, fault offset 0x0d26e30f, process id 0x1180, application start time 0x01c75cae13960a41.

it would crash completely randomly, even if i had closed all crystal reports and was working in a style sheet or other such harmless file. As i later found out, it was because the solution opened by default with the last crystal report i was working on, and this seemed to start some crystal report ActiveX thing that craps out on Vista.  sometimes it would take 2 minutes and sometimes 5 minutes, but it would always crash, even if i closed the report straight away.  The only way to get rid of it was to load up VS, close the report immediately and safely close VS before it got a chance to crash!  then next time it opens, there is no crystal report and the ActiveX control never loads.  it works ok now, although this is just one of a long list of complaints i have with VS 2005.  i think i'm allergic to crystal reports.


Friday, 02 March 2007 09:58:51 (GMT Standard Time, UTC+00:00)  #    Comments [5]  .Net General | Asp.Net

Tuesday, 10 April 2007 02:34:01 (GMT Daylight Time, UTC+01:00)
Hi,

Are you able to tell me any detaisl on this activeX control ? I have teh identical problem but using Delphi. IT happens with versins as far back as 5 and as late as v11. But the users are now getting really peeved off. I have even created a tiny app to prove the bug... but will the support run it ? NO. Instead they want me to keep answering silly questions. Aaargghh.

The app is so basic that it is obvious that there is a major flaw in Crystal.
Rohit Gupta
Tuesday, 10 April 2007 08:51:09 (GMT Daylight Time, UTC+01:00)
hi rohit,
unfortunately i don't know anything about it. crystal reports is a real pain to develop with, but once it's up and running i find it works quite well.
tim
Thursday, 02 August 2007 19:24:59 (GMT Daylight Time, UTC+01:00)
I had the same problem. Any fix for this?
Vin
Sunday, 30 September 2007 12:06:40 (GMT Daylight Time, UTC+01:00)
Yes, I face the same problem as well and it causes me alot of pain!
I did not notice it was Crystal Report that causing the problem after you mention it!
Thanks...
Ho
Wednesday, 05 December 2007 17:05:18 (GMT Standard Time, UTC+00:00)
Thanks for the temporary solution. I'm experiencing the exact same thing.

Rory
Rory
OpenID
Please login with either your OpenID above, or your details below.
Name
E-mail
Home page

Comment (Some html is allowed: a@href@title, strike) where the @ means "attribute." For example, you can use <a href="" title=""> or <blockquote cite="Scott">.  

[Captcha]Enter the code shown (prevents robots):

Live Comment Preview