.Net ramblings
# Thursday, 05 July 2007
Vista Driver problems, Formac USB Hard Drive
i just got a 160Gb Formac portable USB/firewire hard drive. I plugged it in to Vista and i get a message saying that Windows needs to install a driver to get it to work, i wasn't expecting this as i thought these drives did not need any drivers.  I let it check Windows Update but it found nothing.  I tried the firewire option but it was no different.  I contacted Formac tech support and got the following reply, which was actually very helpful:
"If a driver is required, then it is required for your USB, or FireWire interface inside your PC. External harddrives didnĀ“t require special drivers, because they are ATAPI compatible."
I grabbed an old USB card reader which i know does not require any additional drivers, and i plugged it in.  I got 12 prompts to install drivers and each time it searched Windows Update and found nothing.  I took a guess at searching in c:\windows and it found them one by one.  I couldn't figure out why Windows would not search its own driver store automatically.  Apparently there is some bug with Vista where you can get a corrupt driver cache file and if you delete it then it will solve all these problems. 
The culprit file is called INFCACHE.1 and it's located in c:\windows\inf.  I discovered this on a newsgroup post.  This is the relevant part:

The solution to this annoying problem (I had it on one PC), seems to be to locate and delete the file INFCACHE.1, which may be corrupted and causing the problem. To delete this file, you will first have to modify its permissions so the users group can access it (right-click on the
file->Properties->Security). INFCACHE.1 file.  It's located at C:\Windows\inf (scroll down to the file). (Note: to see INFCACHE.1, you must set Windows Explorer to display hidden and system files)

When modify these system files, i usually find i have to take ownership first for my own user account, then add myself to the permissions with full control.  then you can delete it, or rename it to X_INFCACHE.1, etc.

I'm glad to say Vista is loading all my USB devices nicely now and the Formac drive works beautifully with USB and Firewire.


Thursday, 05 July 2007 10:18:30 (GMT Daylight Time, UTC+01:00)  #    Comments [32]  General